Back
Maintenance

Maintenance on CP01 and CP06

Completed 24 Oct at 04:30pm EEST.

CP01 CP06
Completed

Maintenance completed

Posted 24 Oct at 04:30pm EEST.
Started

There will be a short down time on CP01 and CP06 on Tue October 24th between 14:00 CEST and 20:00 CEST.

Posted 24 Oct at 02:00pm EEST.