Back
Resolved
Resolved
The is an ongoing external incident of Cloudflare
Started , resolved .
Frontend
Billing API
Resolved
Seems that Cloudflare is back so our frontend is back too
Posted .
Created
Cloudflare incident affecting a lot of websites access including cloudboxes.io services. This only applies in some regions.
more on the issue at https://www.cloudflarestatus.com/
Posted .